LINUXGAMES

Quake 4 v1.4 Beta

February 8th, 2007 by Crusader

Version 1.4 beta of Quake 4 has beenreleased by id Software. Changesinclude:

  • Refined hitboxes
  • Optimized sound and network code
  • Configurable fps caps
  • Weapon balancing
  • Server direct autodownloading
  • Addonpak fixes
  • Spectating via Q4TV

This build is not compatible with version 1.3; you’ll only be able to play onother v1.4 beta servers, or use savegames created with this release. Pleasereport bugs to q4bugs@idsoftware.com; also,developers can now download the updated SDK from idDevNet.

Download: [ idsoftware.com ]

10 Responses to “Quake 4 v1.4 Beta”

  1. Anonymous Says:

    I’m thinking of upgrading to a Nvidia GeForce-8800-GTX. You think its worth the damage?
    What about HDCPI or HDMI stuff?
    Is there away I can get around this HD protection crap, or is it just me reading to far into it?

  2. Anonymous Says:

    Correction:
    What about HDCPI or HDMI stuff?

    I meant HDCP or HDMI. I’m not sure what made me think of the other :(

  3. kccricket Says:

    I’m not sure those technologies are particularly applicable to Linux, but I could be wrong.

  4. Anonymous Says:

    I don’t think it’s worth it for Quake 4. If you plan on playing UT3 though that’s another matter. Especially if you have a big screen.

  5. Anonymous Says:

    exactely what are you talking about? never heard about HDCPI before

  6. Anonymous Says:

    HDCPI?

    I’m not sure how I came out with that. But I was ment to say HDCP.

  7. Anonymous Says:

    I’d satisfied if they just fixed the v1.3 SMP breakage. Sigh.

  8. ZlatkO Says:

    SMP breakage? What’s wrong with SMP on 1.3? Haven’t noticed anything so far – but then again, I haven’t been playing Q4 much lately.

  9. Anonymous Says:

    >SMP breakage? What’s wrong with SMP on 1.3? Haven’t noticed anything
    >so far – but then again, I haven’t been playing Q4 much lately.

    On my system (FC4, dual Xeon CPUs) v1.3smp causes the game to hang when starting cutscene playback. The screen goes black, suggesting that the cutscene playback is starting. And then it stays black, forever.

    Running 1.3up plays the cutscenes correctly. I suspect that id introduced some sort of race condition in the 1.3smp code, because 1.2smp worked fine and so does 1.3up.

  10. ZlatkO Says:

    [q]On my system (FC4, dual Xeon CPUs) v1.3smp causes the game to hang when starting cutscene playback.[/q]Thanks for letting me know, I’ll try to remember to use the non-SMP version the next time I play Q4. ;-)

Leave a Reply

You must be logged in to post a comment.