LINUXGAMES

Linux Quake 4 FAQ

October 19th, 2005 by Crusader

The id Software Quake 4 Linux FAQ page is online. The news section notes:

Wed Oct 19 07:12:16 CDT 2005

We are preparing the release of the Quake4 GNU/Linux installer. The GNU/Linux version of Quake 4 is not available yet.

Quake 4 shipped to retailers yesterday; here are the listed system requirements:

  • GNU/Linux system
  • Pentium(r) 4 2.0 GHz or Athlon(tm) XP 2000+ processor
  • 512MB RAM
  • Kernel 2.4, 2.6 is recommended
  • glibc >= 2.2.4
  • 3D acceleration ( not required for dedicated server ):
    • SDL >= 1.2
    • latest OpenGL drivers, correctly configured
    • ATI(r) Radeon(r) 9700
    • ATI Radeon 9800
    • ATI Radeon X300 series
    • ATI Radeon X550 series
    • ATI Radeon X600 series
    • ATI Radeon X700 series
    • ATI Radeon X800 series
    • ATI Radeon X850 series
    • Nvidia(r) GeForce(TM) 3/Ti series
    • Nvidia GeForce 4/Ti series
    • Nvidia GeForce FX series
    • Nvidia GeForce 6 series
    • Nvidia GeForce 7 series
  • Audio ( not required for dedicated server ):
    • sound card with OSS or Alsa support, stereo and surround sound are supported wth both APIs
    • Alsa >= 1.0.6 is required for alsa sound backend
  • Multiplayer:
    • Internet (TCP/IP) and LAN (TCP/IP) play supported
    • Internet play requires broadband connection

Installation instructions are also delineated; it should be noted that the German version of Quake 4 has different asset files than other territories.

10 Responses to “Linux Quake 4 FAQ”

  1. Anonymous Says:

    I hope to see how it plays on my computer if they release a Linux demo.

  2. Anonymous Says:

    It’s killing me!

  3. Anonymous Says:

    Regarding the German version, from the FAQ: “Note that it will only work in multiplayer with other german copies of the game.”

    So I guess I won’t be playing against any German Quake4 players then, does anyone know why? :(

  4. Anonymous Says:

    I’m from Germany, and i’m certainly *not* going to buy the German version…Anyway, i’m going to wait for the linux client first, but then i’ll buy an imported copy.

  5. Anonymous Says:

    I orderded the game today, but i am only able to playt it under Gentoo. Can’t wait!!!!

  6. Anonymous Says:

    I suspect not, judging by doom3, i know about lms and opencoop.

    Anyhow wait and see i guess , will wait for the downloads and maybe check it out.
    But it will probably be serious sam II that i shall buy. It has solid
    singleplayer:coop and it sound like there may be a linux client in the works ??.

  7. Anonymous Says:

    What the hell is different with the German version? Why would they exclude anything? Is there some, well…., you know, “symbols” or something from the past?

  8. Anonymous Says:

    cant wait

  9. Anonymous Says:

    Nuff said, go buy it guys.

  10. klonsemann Says:

    Hello guys.

    First time on this site. Nice to see the linux gamer section growing. Cause of that our D³ COOP Mod has Linux support ;-).

    We are just having a look at the Q4 SDK and SP-Maps to decide if coop for Q4 realizable.

    Stay tuned and hav a look at our site [b]www.d3opencoop.com[/b]

    klonsemann

Leave a Reply

You must be logged in to post a comment.