LINUXGAMES

Devastation Linux client beta1

May 2nd, 2003 by Marv

Several people have written telling about the latest port from our friend, Icculus, this time being Devastation. To play this games under your favorite operating system, you will need the retail disc, a win32 system to install/patch and ,of course, a valid CD key.
Download

15 Responses to “Devastation Linux client beta1”

  1. Anonymous Says:

    icculus is a person, not a place!

  2. Anonymous Says:

    It works perfectly except the Game Save thumbnail picture does not display.

    Great job!UT2k3,SSAM,Devastation…what is the next?

  3. kccricket Says:

    * gasp *

    Tuxgames isn’t taking pre-orders yet!

  4. Anonymous Says:

    Anyone else have sound problems? I have sb live and I get no sound :/

  5. Anonymous Says:

    This game got such bad reviews that maybe all these linux people who buy every game for linux would actually have a large part of the sales on this one

  6. Anonymous Says:

    the same 4 me :(

  7. Anonymous Says:

    http://icculus.org/~ravage/devastation/

    Might work. :)

  8. Anonymous Says:

    So why use the shitty port?

  9. Anonymous Says:

    yep , i dont get sound … any ideas anyone? — using a nforce2 mobo (shuttle PC )
    Rob

  10. bobcat Says:

    How’s this thing run? Considering the really bad performance I get on UT2003 I am hesitant to burn another $50 on another UT2k3 engined game. Mind you, I can get ut2k3 to run ok, once all the features are off and I’m at 800×600. Which is not an option in 2003 with the halfway decent hardware I have.
    I know it’s time to upgrade from my GF3ti200, and the FX card should have been it, but it looks like I need to wait for the next generation from nVidia. I’m babbling again. How’s Devastation run?

  11. bobcat Says:

    Soooooo no one can tell if this runs worth a poop or not?

  12. Myth Says:

    When i begin a game, the screen “press fire key to start” freezes and i can ear the game, but the shitty screen continues !!!!

  13. Anonymous Says:

    I got this game installed and had no sound. I copied my openal.so from UT2003 int the ~/devastation/System. After doing that sound worked great. The game runs very good on my P4 2.4 w/gf4ti4200 and my #2 system AMD 1.4 w/ GF3ti200. It is a memory hog I noticed!!! But both my systems have 512M ram and I never saw a slowdown… go get it…give icculus some feedback… get the dedlinux server also…

  14. Anonymous Says:

    Sure I gonna rush out and buy a game, that I don’t know how is going to work on my system.
    Please port the demo, so I can try it out.

  15. Anonymous Says:

    Where can I get the patch to take it up to 381; the best I can find goes to 380. Thanks in advance.

Leave a Reply

You must be logged in to post a comment.