LINUXGAMES

UT2003 Linux Patch 2166 Released

December 21st, 2002 by Marv

Several people have written in pointing out the release of the new UT2003 Linux Patch, version 2166. The very long changelog can be read in full, if you desire, here

[update by Matt]
According to this post on the DRI mailing lists, this patch allows UT2k3 to run without S3TC, and thus DRI-enabled cards may now have a chance to play. I haven’t had an opportunity to test it, but perhaps some of our readers could try it out.

Mirrors: 3D Downloads

9 Responses to “UT2003 Linux Patch 2166 Released”

  1. Anonymous Says:

    test

  2. Anonymous Says:

    This patch has made the game *extremely* slow on my system. I changed back to the previous patch and problem went away. This is with a GF4 Ti4600 and 3123 NVIDIA drivers. I wonder if they took out the S3TC for *all* cards?

  3. Anonymous Says:

    This patch allows all the graphics accelerators with DRI support to run UT2003. Way to go! Now if only UT2003 would run on my K6-2; please don’t optimize for Pentium Pro or at least release a post-patch that patches Pentium Pro optimizations with K6-2 and athlon.

    If only they would release a port for other platforms…

  4. Anonymous Says:

    I was really pumped about this game running under Linux, but I don’t play it since the OpenGL renderer runs like crap on my system, which is an Athlon XP 2000+ based system with 256MB of DDR and a GF4Ti 4200. Not a shabby system.

    Why didn’t they design the game from the ground up to be cross platform if they planned to release a Linux port?

    I hope some future game developers don’t choose the UT2k3 engine for their mod over the Doom 3 engine because while the UT2k3 engine is technically cross platform, the performance on platforms other than Windows is terrible.

  5. Anonymous Says:

    I have a Radeon 64MB DDR VIVO graphics card and when I run ut2003 all I get is this:
    Xlib: extension “XiG-SUNDRY-NONSTANDARD” missing on display “:0.0″.
    GL_EXT_bgra not supported – bailing out.

    History:

    Exiting due to error

    How do I get it to work right?

  6. Anonymous Says:

    Does it still crash after a few minutes on Suse 8.1? I have a R200 with the newest fglrx installed, and i got crashes after a minute or two. I switched back to old RH7.3 and had no problems. Any thoughts?

  7. castalia Says:

    So, i battled my way through the perils of the ut2k3 install. I get this all working, and suddently at every map cahnge my i cant fire to join the game. However if i leave the server then join it works. Has anyone else had a similar issue?

  8. Anonymous Says:

    It works well for me except that I have a cable modem and I’m downloading new maps consistently at 5k a second like a phone modem even though I put the network connection setting to “cable/Adsl”. Anybody else having this problem?

  9. Anonymous Says:

    ive got rh8 installed on a p4 2ghz. with a GeForce 2 MX 64mb. and this is as far as i get with the patch……

    =============================================================
    Would you like to apply this update? [Y/n]: Y

    =============================================================
    Performing update:
    ERROR: No matching delta for /usr/local/games/ut2003/System/XWebAdmin.u
    The program returned an error code (3)

    anyone got any ideas??

Leave a Reply

You must be logged in to post a comment.